Rechercher sur ce blogue

jeudi 8 octobre 2015

Pourquoi désinstaller les anciennes versions de Java de mon système ?

Pourquoi désinstaller les anciennes versions de Java de mon système ?


Cet article s'applique aux éléments suivants:
  • Plate(s)-forme(s): Windows 7, Windows 8, Windows XP, Windows Vista, Windows 10

Utilisateurs Windows : améliorez la sécurité de votre ordinateur en recherchant les anciennes versions de Java et en les supprimant lorsque vous installez Java 8 (8u20 et versions ultérieures) ou à l'aide de l'outil de désinstallation Java.

» En savoir plus sur l'outil de désinstallation Java

Il est toujours recommandé d'utiliser la dernière version de Java car elle contient des mises à jour de fonctionnalité, des corrections de vulnérabilité et des améliorations de performances par rapport aux versions précédentes. Pour vérifier que vous disposez bien de la dernière version, rendez-vous sur la page de vérification Java ou vérifiez manuellement la dernière version de Java.

Dois-je désinstaller les anciennes versions de Java ?

Il est fortement recommandé de désinstaller l'ensemble des anciennes versions de Java du système.
La conservation des anciennes versions de Java sur un système présente un risque important pour la sécurité.
La désinstallation des anciennes versions de Java du système permet de garantir que les applications Java seront exécutées avec les dernières améliorations en matière de sécurité et de performance.

Comment puis-je supprimer les anciennes versions de Java ?

Les utilisateurs de Windows peuvent désinstaller en toute sécurité les anciennes versions de Java :

Comment puis-je supprimer Java de mon ordinateur ?

Windows : vous pouvez désinstaller les versions de Java manuellement de la même manière que vous désinstalleriez tout autre logiciel de votre ordinateur Windows. Suivez les instructions figurant sur la page relative à la désinstallation manuelle de Java pour Windows.
» Instructions de désinstallation de Java pour Mac
» Instructions de désinstallation de Java pour Linux

Ai-je besoin des anciennes versions de Java ?

La dernière version disponible est compatible avec les anciennes versions. Cependant, certaines applications (ou applets) Java peuvent stipuler qu'elles dépendent d'une version particulière, auquel cas il est possible qu'elles ne puissent pas être exécutées si la version en question n'est pas installée. Si une application ou une page Web requiert une ancienne version de Java, signalez-le au fournisseur/développeur et demandez-lui de mettre à jour l'application afin de la rendre compatible avec l'ensemble des versions de Java.

Les éléments suivants pourraient également vous intéresser:
Comment désactiver Java dans un navigateur Web ?

Le plug-in Java ne fonctionne pas dans Firefox après l'installation de Java


Cet article s'applique aux éléments suivants:
  • Navigateur(s): Firefox
  • Version(s) de Java: 7.0, 8.0

Message d'avertissement de Firefox : les add-ons peuvent causer des problèmes

Le message suivant apparaît lorsque vous lancez le navigateur Web Firefox. Il contient un avertissement :
Firefox a déterminé que les add-ons suivants provoquent des problèmes de stabilité ou de sécurité.

Cause
Les anciennes versions de la boîte à outils de déploiement Java (DT) et du plug-in Java sont désactivées par Firefox. Dans certaines versions de Java, il est possible que Firefox génère un message du type : "les add-ons peuvent causer des problèmes".
Si Firefox considère qu'un add-on n'est pas sûr et peut représenter un risque pour la sécurité, il bloque son chargement. En cas de blocage souple, Firefox présentera un message d'avertissement mais cela n'empêchera pas l'utilisateur de poursuivre s'il le souhaite, mais avec la mise en péril de la sécurité. En cas de blocage strict, Firefox bloquera l'installation afin que l'utilisateur ne puisse pas utiliser cet add-on. Pour résoudre ce problème, l'utilisateur doit effectuer une mise à jour vers la dernière version de Java.
Solution de contournement
La mise à niveau vers la dernière version de Java 7 doit normalement résoudre le problème. Si ce message d'avertissement apparaît, procédez comme suit :
  1. Vérifiez que la case Désactiver est cochée.
  2. Cliquez sur Redémarrer Firefox.
  3. Téléchargez la dernière version de Java.

Java ne fonctionne pas dans Firefox en raison d'une installation autonome de JavaFX

A la fin de l'installation de Java 7u10 et versions supérieures, l'erreur suivante apparaît :
Erreur : un plug-in est nécessaire pour afficher ce contenu. Installer le plug-in

Cause
Cette erreur peut être due à un conflit entre Java 7u10 (et versions supérieures) et des installations autonomes de JavaFX. Exemple : si Java 7u5 et JavaFX 2.1.1 sont installés et que Java est mis à jour, Firefox ne peut pas détecter que la dernière version de Java est installée.
Solution de contournement
Supprimer la version autonome de JavaFX (Windows)
  1. Localisez et supprimez toutes les versions de JavaFX et Java via le Panneau de configuration de désinstallation de Windows.
  2. Exécutez l'utilitaire de désinstallation Microsoft pour réparer les clés de registre endommagées qui empêchent la désinstallation complète des programmes ou qui bloquent les nouvelles installations et les mises à jour.
  3. Réinstallez Java.


Outil de désinstallation java ici.

Source.:

Aucun commentaire: